[mpich-discuss] mpich2-1.3rc2.tar.tar under cygwin+WINDOWS Server 2003 R2 installation problem

jayesh at mcs.anl.gov jayesh at mcs.anl.gov
Tue Oct 12 10:52:51 CDT 2010

>> ...mpich2-1.2.1p1-win-x86-64.msi... mpiexec answered something like smpd was not the right version.

 Did you install MPICH2 from an administrator command prompt ? Windows flavors Vista/7/Srv2008 need extra information in the installers for installing the package as an administrator (The flavor of Visual Studio that we use to compile MPICH2 does not support adding these additional info - We have an open ticket on this issue, https://trac.mcs.anl.gov/projects/mpich2/ticket/1070, and we plan to fix it soon).
 We do not recommend users to use "smpd -install" to install SMPD on windows (Unless you know what you are doing). The windows installer should automatically install the process manager for you.
 Please follow the steps below and let us know if it works for you,

# Uninstall any versions of MPICH2 installer in your machine (Control panel --> Add/Remove programs --> Uninstall)
# Right-click on the command prompt icon and select "Run as administrator" (Note that opening a command prompt as an administrator does not give you an administrator command prompt). This opens an administrator command prompt
# Use the msiexec utility to install MPICH2 (Type "msiexec /i mpich2-1.2.1p1-win-x86-64.msi" at the administrator command prompt) from the administrator command prompt
# The command above pops up the installer GUI to install MPICH2.
# After installing MPICH2, type "mpiexec -n 2 hostname" at the command prompt to check if MPICH2 is working (The MPICH2 job launcher might prompt you for user credentials to launch the executables. Provide them when prompted.).
# Compile/Run a simple hello world program (https://svn.mcs.anl.gov/repos/mpi/mpich2/trunk/examples/f77/hellow.f)

 Installing MPICH2 on windows using an installer would be the easiest way to getting started with MPICH2 on windows (and you get better performance than MPICH2 on Cygwin).
 Let us know the results.


----- Original Message -----
From: "Victor Gillette" <victor.gillette at ncsu.edu>
To: mpich-discuss at mcs.anl.gov
Sent: Tuesday, October 12, 2010 10:30:30 AM GMT -06:00 US/Canada Central
Subject: [mpich-discuss] mpich2-1.3rc2.tar.tar under cygwin+WINDOWS Server 2003 R2 installation problem

Hi. I am interested in running MCNP parallel on a Windows Server 2003 R2 64
bits System with Intel fortran Compiler and cygwin installed and working.

First I tried installing


but mpiexec answered something like smpd was not the right version.

Then I ran smpd -install

and when trying to run mpiexec nothing happened.

I read that hydra would be a more robust manager instead of smpd, so I
downloaded the source files of


because the pages with binaries were not available and I ran

make install

I found some issues while make, like datatypes for Fortran were not defined
in mpi.h of mpif.h . What I did to patch these problems is copying the
values for these definitions from the mpif.h and mpi.h files of the previous
version I had installed. I have no idea if this is completely crazy or a
reasonable assumption, but make ended OK. There was another issue which was
that a file setbotf.o was not found in binding/f77 but I found the
file setbotf.obj , so I
renamed the file to have .o extension and make and make install ended

I was able to compile Hiworld.c but it doesn't run. I was not able to
compile Hiworld.f (datatypes ended with ")" when something else was expected.

I created all MPICH twice the first time with all defaults, which
produced HYDRA, and a second time with MPD because I found no
explanation about how to start HYDRA in the manual.

With MPD I defined the file .mpd.conf in my home folder and the file
mpd.conf in the /etc folder

I started MPD with

mpd --ncpus=8 &

and if I type


the code answers my system name.

if I type

mpiexec -n 4 ls

the output of ls is shown 4 times on the screen.

I can create a.exe with

mpicc Hi.c

successfully, however these are the outputs of different commands I tried:

$ mpiexec Hic.exe
missing num_proc flag: -n, -np, -hosts, or -localonly.
Unable to parse the mpiexec command arguments.

vhgillette at TRISO /cygdrive/e/Victor/MCNP/CHECK/VIC/test
$ mpiexec -n 2 Hic.exe

vhgillette at TRISO /cygdrive/e/Victor/MCNP/CHECK/VIC/test
$ ./Hic.exe
 argx  2280688   argv  ô
Hello from processor 0 of 1

so, please, could anyone ive me some advise about how to run mpi
successfully on my system?


mpich-discuss mailing list
mpich-discuss at mcs.anl.gov

More information about the mpich-discuss mailing list