[mpich-discuss] Windows 7 64 problems with credentials (tried many things)

Jayesh Krishna jayesh at mcs.anl.gov
Tue Oct 5 13:42:13 CDT 2010

 Can you send us the smpd log ?

----- Original Message -----
From: "Jim Hunziker" <jhunziker at bcisensors.com>
To: mpich-discuss at mcs.anl.gov
Sent: Tuesday, October 5, 2010 1:18:52 PM GMT -06:00 US/Canada Central
Subject: [mpich-discuss] Windows 7 64 problems with credentials (tried many things)

I'm getting "Credentials for JAHWIN7\jhunziker rejected connecting to jahwin7" messages in Windows 7 64-bit. 

I installed the 64 bit version of 1.2.1p1, though I had the same problems with the 32 bit version. The installation was done with msiexec /i mpich2-1.2.1p1-win-x86-64.msi at an Administrator prompt. The installation was done for "Everyone". 

As a regular user (who does have a password), I ran mpiexec -register to get my credentials in the registry. mpiexec -validate returns SUCCESS. I also did this step as a newly created user, in case there was something weird about my environment. The password is simple and alphanumeric. 

When I use mpiexec to launch a program, it fails with the credential error. If I look in the Windows Event Viewer, I can see a successful login has been recorded. 

If I run smpd -d to see the debug lines, there is an assertion failure in smpd_affinitize.c on line 157. I believe this an unrelated bug because mpiexec then fails with "op_read error on left context: Error = -1" rather than the credentials error. Since this failure is related to process affinity, I wonder if there's a problem relating to my using two processors in my machine, which is a VirtualBox virtual machine. 

Any help would be greatly appreciated. 

Jim Hunziker 

mpich-discuss mailing list
mpich-discuss at mcs.anl.gov

More information about the mpich-discuss mailing list