[mpich-discuss] MPI problem on BGP/ZeptoOS

Francisco Javier García Blas fjblas at arcos.inf.uc3m.es
Tue Jan 27 17:15:01 CST 2009

El 27/01/2009, a las 21:32, fjblas at arcos.inf.uc3m.es escribió:

>> On Tue, Jan 27, 2009 at 03:47:26PM +0100, Francisco Javier García  
>> Blas
>> wrote:
>>> I have a problem with ZeptoOS on BGP. Some weeks ago, I updated to  
>>> the
>>> last version of ZeptoOS (now I am using version the lasted version,
>>> 2509). ZeptoOS kernel images look work fine all the time.
>>> First, I checked this new version submiting a simple mpi test  
>>> (included
>>> in the comm folder of ZeptoOS). It worked fine.
>>> My next test consisted in running a I/O job (BTIO benchmark, 64
>>> processes, type B).  I found two bugs in ROMIO: the first one  
>>> calling
>>> MPI_Type_get_envelope primitive (the nints parameter returns a wrong
>>> value in flatten.c) and the second one inside ad_write_coll.c  
>>> (locked
>>> into ADIOI_Calc_my_off_len).
>> Hi Javi.  Definitely sounds like you found a bug.  did you also find
>> this behavior on a linux system, or only on bluegene?
>> ==rob
>> --
>> Rob Latham
>> Mathematics and Computer Science Division    A215 0178 EA2D B059 8CDF
>> Argonne National Lab, IL USA                 B29D F333 664A 4280 315B
> Hi again Rob, thanks for your fast response.
> This problem only appears when I launch a job in the kernel mode. If I
> launch a job in the native kernel mode, all work fine (using the  
> previous
> version DCMF). So, I guess that the bug is in the DCMF library  
> because I
> use the same mpich2 version.
> I'll try link my bench with the lasted compiled mpich plus the  
> previous of
> the DCMF libraries.
> Thanks for all

Hi again,

I just discover that my "old" libraries work with the new linux  
kernel. I can use ZeptoOs now, but the problem is not really solved in  
the lasted version. I hope future releases solve these bugs.

Thanks for all Rob

More information about the mpich-discuss mailing list