[mpich-discuss] MPI problem on BGP/ZeptoOS

Francisco Javier García Blas fjblas at arcos.inf.uc3m.es
Tue Jan 27 08:47:26 CST 2009

Hello all,

I have a problem with ZeptoOS on BGP. Some weeks ago, I updated to the  
last version of ZeptoOS (now I am using version the lasted version,  
2509). ZeptoOS kernel images look work fine all the time.

First, I checked this new version submiting a simple mpi test  
(included in the comm folder of ZeptoOS). It worked fine.

My next test consisted in running a I/O job (BTIO benchmark, 64  
processes, type B).  I found two bugs in ROMIO: the first one calling  
MPI_Type_get_envelope primitive (the nints parameter returns a wrong  
value in flatten.c) and the second one inside ad_write_coll.c (locked  
into ADIOI_Calc_my_off_len).

Additionally, I  tried to compile my own DCMF, CCMI and MPICH  
libraries but I did not resolve the problem.

I guess the problem could be inside MPI's DCMF libraries because all  
MPID files are the same on both versions of MPID.

If you need, I could give you more details off-line.

Best regards.

More information about the mpich-discuss mailing list