[mpich-discuss] Assertion failed

Rajeev Thakur thakur at mcs.anl.gov
Fri Dec 5 08:56:29 CST 2008

If you are using MPICH2 1.0.8, try the Nemesis channel instead of the
regular sock channel. Configure with --with-device=ch3:nemesis.


> -----Original Message-----
> From: mpich-discuss-bounces at mcs.anl.gov 
> [mailto:mpich-discuss-bounces at mcs.anl.gov] On Behalf Of Xavier Olive
> Sent: Friday, December 05, 2008 4:50 AM
> To: mpich-discuss at mcs.anl.gov
> Subject: Re: [mpich-discuss] Assertion failed
> Hello again,
> I compiled mpich2 (last version) + mpijava on a completely different
> machine/architecture.
> 1. My test worked without problems.
> 2. I ran my algorithm and after some thousands of messages exchanged,
> still the same error. (Assertion failed etc.)
> 3. I ran my algorithm again and crash with the same "failed assertion"
> for one of the first MPI directives.
> At least, I could reproduce the problem on a completely different
> machine. Since my simple tests don't fail, I don't know Darius what I
> have that could help you...
> Xavier

More information about the mpich-discuss mailing list