[mpich-discuss] (no subject)

ting lei leitingl at hotmail.com
Tue Dec 2 13:31:01 CST 2008


This might be a newbie question.
I see in this thread that people can compile MPICH2 with MingW. I tried that with MingW (gcc 4.3 and 3.4x) several times but 
I was never able to get past the ./configure step. 
"I have compiled a C executable using the MPICH2 Windows libraries and MinGW."
Could someone please give me some pointers how to compile such an executable?
More specifically, do I have to compile MPICH2 itself from source using MinGW then use some program such as mpicc?? 
or should I just compile a regular c program and run it with mpiexec.exe ?
If I were to compile MPICH2 itself with MingW, what other packages do I need except the latest version of MingW?

Many thanks for your help


--Original Message----
  This is a bug in the current state machine of SMPD. This should not
affect the execution of your MPI program (This error occurs when the
process manager tries to cleanup connections after the MPI program
finishes execution).

(PS: You can go ahead with your program development and ignore the
closesocket() errors for now. We will fix this bug soon.)

-----Original Message-----
From: mpich-discuss-bounces at mcs.anl.gov
[mailto:mpich-discuss-bounces at mcs.anl.gov] On Behalf Of Dmitri Chubarov
Sent: Tuesday, November 11, 2008 1:23 AM
To: someindianbloke at gmail.com
Cc: mpich-discuss at mcs.anl.gov
Subject: Re: [mpich-discuss] closesocket failed error when running an
MinGWcompiled executable.


Error 10093 is a winsock error code for "Successful WSAStartup not yet
performed". Do check if you get the same error on other machines to rule
out network misconfiguration in your Windows installation.

On Tue, Nov 11, 2008 at 7:02 AM, Chiraj <someindianbloke at gmail.com> wrote:
> Hi,
> I have compiled a C executable using the MPICH2 Windows libraries and 
> MinGW. I have tried running the executable using "mpiexec -localroot 
> -localonly 2 main.exe 0.xml", but I get the following error:
> closesocket failed, sock 1284, error 10093
> Could some please tell me what this means I am doing wrong? I have 
> tried searching everywhere on what this error means. I have registered 
> my user credentials using wmpiregister and checked if I have started 
> smpd as a windows service. I am running Windows Xp Professional SP3 on 
> an Intel Pentium 4 base system.
> Chiraj

You live life online. So we put Windows on the web. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/mpich-discuss/attachments/20081202/a629144c/attachment.htm>

More information about the mpich-discuss mailing list