FW: [mpich-discuss] mpdtrace cannot connect (cygwin & mpd), previous smpd remnants?

Ingo Bojak I.Bojak at science.ru.nl
Tue Apr 29 05:43:57 CDT 2008

Jayesh Krishna wrote:
>   Did you install Cygwin after logging in as "ibojak" ? Is user "ibojak" in
> the Administrators Group (If you recently added ibojak to the Administrators
> group did you do a "mkpasswd -l > /etc/passwd" "mkgroup -l > /etc/group" ?
> Make sure that you save a backup of /etc/passwd and /etc/group before
> overwriting them.)?
> (PS: During Cygwin installation I think there is an option to select whether
> the installation is for "only the current user" or "all users". I usually
> select "all users" to get out of permission troubles later on  :) The
> permission pblms will kill you if you try to setup ssh in your machine.)
I've finally had time to work on this again. I tried a complete 
reinstall just from Cygwin's setup.exe, but with no joy. What finally 
did work was to wipe Cygwin completely. The following is a how-to for 
that from Thorsten Kampe at the Cygwin site:

--- http://cygwin.com/ml/cygwin/2004-06/msg00964.html ---

To uninstall Cygwin you have to:

rmdir /s /q C:\cygwin
regdit -s rmcygwin.reg


[-HKEY_CURRENT_USER\Software\Cygnus Solutions]

Then I reinstalled the lot and found that this time the access rights 
were set as on my laptop (where everything works). So indeed when I 
reinstalled MPI it finally worked.

Thanks for the help,

More information about the mpich-discuss mailing list