[AG-TECH] Accessgrid 3.1 can't unmute local video displays

Thomas D. Uram turam at mcs.anl.gov
Thu Mar 27 11:18:35 CDT 2008

A few comments here:

- You should be running a VideoConsumerService or VideoService on the 
display machine, so that incoming video streams are displayed.  The only 
case in which the video streams are muted, and hence the only case in 
which you would need to 'unmute' them, is when you are running 
VideoProducerServices; you should not be using these vic instances for 
displaying the video streams.
> We had previously run 2.4, and probably there was an old vic.exe 
> lurking within. 
- AG3 stores its files in different locations than AG2 did, so any 
vic.exe from AG2 could not have been used when running AG3.

- What are you referring to as the "AccessGrid toolkit" application?  
Does it have an associated window?  The AccessGrid software that should 
be running is the Venue Client; without it, you would be left with only 
the audio and video tools.

If you have any questions, please let me know.


On 2/13/08 11:55 AM, Felix Terkhorn wrote:
> Hi Tom,
>   Thanks for your suggestions, which did prove helpful (although we 
> found a nasty bug in the AG toolkit, described below).
>   As you suspected, we were using the VFW driver for our Videum card.  
> We uninstalled this driver, rebooted, and installed the new DirectShow 
> (WDM) driver for our card.  This allowed us to add video producer 
> inputs under a new name.
>   We also followed your directions in deleting the folders under 
> c:\documents and settings\<our user>\application 
> data\accessgrid3\local_services.  We had previously run 2.4, and 
> probably there was an old vic.exe lurking within.
>    But we still encountered basically the same behavior after doing 
> these steps, although we managed to get the client to let us unmute 
> our video during 1 of our roughly 15 tries after we followed your 
> directions.
>    It turns out that the major culprit responsible for the major 
> problem we had encountered -- not being able to use the mouse in about 
> 50% of the AccessGrid windows -- was the "AccessGrid toolkit" 
> application.  We didn't use this during our previous 2.4 
> installation.  When we upgraded to 3.1, it was installed on our 
> machine, and it looked rather innocuous.  Only when I exited the 
> application was I able to use the mouse in a sane fashion... the 
> mute/unmute checkboxes behaved just fine once this program was 
> terminated.
>    So, thanks again Tom for pointing out the driver upgrades and the 
> purge of old user info.  But word to the wise (and the powers that be 
> on this list) -- AccessGrid toolkit application doesn't play nice with 
> everyone!
> Best regards,
> Felix Terkhorn
> Thomas D. Uram wrote:
>> Felix:
>> A couple questions:
>> - Did you have an earlier version of the AG installed on this 
>> machine?  If so, you may be using an older version of vic.  You 
>> should remove everything under c:\documents and 
>> settings\<you>\application data\accessgrid3\local_services, and try 
>> again.  This will ensure that you are using the most recent vic 
>> executable.
>> - Are you using the VFW or WDM driver for your Videum card?  The use 
>> of the 'external-in' port hints that you're using the vfw driver and 
>> that you should update.  (The vfw driver should be becoming harder 
>> and harder to find.  If you are using it, it should be clearly 
>> identified as vfw, whereas the wdm driver probably has no clear 
>> designation.)
>> Tom
>> On 2/13/08 9:36 AM, Felix Terkhorn wrote:
>>> Hello AG wizards,
>>>   We've been trying to set up our AccessGrid 3.1 client here at 
>>> Indiana University.  We are using Python 2.4, Python 2.4 win32 
>>> extensions, wxPython 2.6.
>>>   We have three cameras connected which, when tested outside of 
>>> AccessGrid, function appropriately.  Our sysadmin has recently 
>>> updated the drivers for these video capture card and we get a clear 
>>> picture from each one when testing with videum configuration 
>>> application.  The video capture card is a Videum 4400VO.
>>>    The problem we're seeing:  We can connect to venues and receive 
>>> video and audio from other sources, and we can transmit audio.  But 
>>> when we try to uncheck the 'mute' checkbox next to our local video 
>>> displays, the checkbox does not respond.   We have three cameras 
>>> configured as video producers with port as external-in, encoding as 
>>> h261, and standard as NTSC.  Only standard gives an alternate 
>>> option, PAL, which also has not worked.
>>>   We've tried both the newest driver for our video capture card, as 
>>> well as rolling back to the driver on the CD that came with the 
>>> hardware.
>>>    On some level this seems like it might be a Tcl/TK problem.  
>>> Besides the 'mute' checkbox being unclickable, we've often observed 
>>> that other windows with "TclTK" in their title (autoplace, for 
>>> example) have no elements that respond to mouse input.  When this 
>>> behavior occurs, even the minimize and maximize buttons on those 
>>> windows do not respond.
>>>   Any help you can offer would be greatly appreciated.  :)  We are 
>>> quickly running out of ideas on how to get this to work.  I'm more 
>>> than happy to provide additional information as needed.
>>>   Best regards,
>>>   Felix Terkhorn
>>>   Indiana University LEAD project developer and general handyman

More information about the ag-tech mailing list