[AG-TECH] AG3.1 and Leopard?

Many Ayromlou mayromlo at ryerson.ca
Thu Feb 14 14:06:41 CST 2008

Hi Todd,

To be honest, I haven't really dug into this lately. I installed 3.1  
on another Leopard machine (PPC 10.5.2) and no go either (same  
errors). I have also tried to remove .Accessgrid folder from both  
machines (thinking it had old stuff in it) and no go........kinda  
stuck right now......don't really want to swap out the python that  
comes with leopard, maybe I'll find a sacrificial machine, time  
machine it, and install the 10.3 recommended python/wxpython stuff to  
see if that's the problem............

I'll report back if I find something new......

BTW Just for everyone's info, both the intel and the PPC Mac's had  
10.4.11 installed and were archive upgraded to 10.5 (don't know if  
this makes any difference).

On 14-Feb-08, at 1:22 PM, Todd Zimmerman wrote:

> Many Ayromlou wrote:
>> Hi All,
>> Has anyone got this combo to work (AG3.1 and Leopard)? I've got it  
>> installed with Python 2.5.1 (r251:54863) (stock OSX 10.5.1) and I  
>> get these errors in system.log everytime I run the app.......
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]: Traceback (most  
>> recent call last):
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]:   File "/Applications/ 
>> AccessGridToolkit3.app/Contents/Resources/bin/AGLauncher3.py", line  
>> 7, in <module>
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]:     agversion.select(3)
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]:   File "/Applications/ 
>> AccessGridToolkit3.app/Contents/Resources/lib/python2.3/site- 
>> packages/agversion.py", line 40, in select
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]:     raise  
>> VersionError('Requested version (%s) of AccessGrid not found' % ver)
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]: agversion
>> Feb  7 15:39:12 yggdrasill  
>> [0x0-0x11c11c].edu.uchicago.AccessGrid[5914]: .VersionError:  
>> Requested version (3) of AccessGrid not found
>> Feb  7 15:39:12 yggdrasill com.apple.launchd[106]  
>> ([0x0-0x11c11c].edu.uchicago.AccessGrid[5914]): Exited with exit  
>> code: 1
>> I understand that Leopard is not supported at this point, but  
>> thought someone might have run into this already and might have a  
>> solution :-)
> Any progress on this?  Does anyone have an updated timeline on 10.5  
> support?
> Thanks!
> Todd

The Moving Finger writes; and, having writ,
Moves on: nor all your Piety nor Wit
Shall lure it back to cancel half a Line,
Nor all your Tears wash out a Word of it

-- Omar Khayyam

More information about the ag-tech mailing list