[AG-TECH] AG3 Bridge issue

Jason Bell j.bell at cqu.edu.au
Fri Apr 27 07:01:35 CDT 2007

G'day Fred

One thing that I do to overcome this problem is I run a daily Cron job
where I restart "my" bridge at midnight each night.  I find this helps a

You may find the following information useful

Hope this helps.


-----Original Message-----
From: Fred Dech [mailto:fdech at uchicago.edu] 
Sent: Friday, 27 April 2007 01:36 AM
Subject: [AG-TECH] AG3 Bridge issue


I've been running a bridge on and off for some time and still run into
the same annoying issue.  After the Bridge process runs for some period
of time and the amount of activity (Quickbridge processes spawned and
destroyed) goes past a certain point, the Bridge stops functioning
properly.  It no longer identifies itself to the registry and no new
entries are added to the log file.  I've tried different FC5 and FC6
platforms, assuming that this problem was machine specific, but this
behavior has not changed.  I also tried running Bridge as root, thinking
that I was running into some kind of restricted buffer limit.  No

The last thing normally logged is some attempts to create new bridges:
04/25/07 14:26:31 -1208707392 Toolkit     Bridge:57 INFO  Bridge
request: mcast 59822
04/25/07 14:26:31 -1208707392 Toolkit     BridgeFactory.py:110 INFO
Method CreateBridge called
04/25/07 14:26:31 -1208707392 Toolkit     BridgeFactory.py:116 INFO
Allocated port = 50076
04/25/07 14:26:31 -1208707392 Toolkit     BridgeFactory.py:123 INFO  -
using existing bridge

and the BridgeFactory uses an existing bridge.

Then the last item in the log is usually the destruction of all the
After that the Bridge might as well not be running, because it doesn't
show up in the registry.
The only think to do at this point is to kill and restart the bridge.

Does this sound familiar to anyone?
I'd appreciate any comments or suggestions.



More information about the ag-tech mailing list