[AG-TECH] AG3 Bridge issue

Michael Miller mimiller at ncsa.uiuc.edu
Thu Apr 26 11:11:25 CDT 2007

I've seen this too.  I believe a bug has been filed...?


At 10:35 AM 4/26/2007, Fred Dech wrote:
>I've been running a bridge on and off for some time and still run into
>the same annoying issue.  After the Bridge process runs for some period of
>time and the amount of activity (Quickbridge processes spawned and destroyed)
>goes past a certain point, the Bridge stops functioning properly.  It no
>longer identifies itself to the registry and no new entries are added
>to the log file.  I've tried different FC5 and FC6 platforms, assuming that
>this problem was machine specific, but this behavior has not changed.  I
>also tried running Bridge as root, thinking that I was running into some kind
>of restricted buffer limit.  No difference.
>The last thing normally logged is some attempts to create new bridges:
>04/25/07 14:26:31 -1208707392 Toolkit     Bridge:57 INFO  Bridge 
>request: mcast 59822
>04/25/07 14:26:31 -1208707392 Toolkit     BridgeFactory.py:110 
>INFO  Method CreateBridge called
>04/25/07 14:26:31 -1208707392 Toolkit     BridgeFactory.py:116 
>INFO  Allocated port = 50076
>04/25/07 14:26:31 -1208707392 Toolkit     BridgeFactory.py:123 
>INFO  - using existing bridge
>and the BridgeFactory uses an existing bridge.
>Then the last item in the log is usually the destruction of all the bridges.
>After that the Bridge might as well not be running, because it doesn't show
>up in the registry.
>The only think to do at this point is to kill and restart the bridge.
>Does this sound familiar to anyone?
>I'd appreciate any comments or suggestions.

More information about the ag-tech mailing list