[AG-TECH] AG3 on Intel Macs

John Dalton John.Dalton at utas.edu.au
Sun May 21 23:39:17 CDT 2006

Hi All,

I'm trying to get AG 3.0.1 running on a MacBook Pro.

If I click on the icon, nothing happens.  If I run the script  
directly I get an error:

casper:~ jrdalton$ /Applications/AccessGridToolkit3.app/Contents/ 
MacOS/runag.sh Traceback (most recent call last):
   File "/Applications/AccessGridToolkit3.app/Contents/Resources/bin/ 
AGLauncher.py", line 8, in ?
     from AccessGrid.Toolkit import WXGUIApplication
   File "/Applications/AccessGridToolkit3.app/Contents/Resources/lib/ 
python2.3/site-packages/AccessGrid3/AccessGrid/Toolkit.py", line 22,  
in ?
     from AccessGrid.Preferences import Preferences
   File "/Applications/AccessGridToolkit3.app/Contents/Resources/lib/ 
python2.3/site-packages/AccessGrid3/AccessGrid/Preferences.py", line  
12, in ?
     from AccessGrid.interfaces.AGNodeService_client import  
ImportError: No module named AGNodeService_client

I have MacPython 2.4.3 installed on this box, which may be a  
problem?  I've tried re-exporting my PATH without MacPython in it  
before running the script, but the result is the same.

Any ideas what I've done wrong?


John Dalton

John Dalton
Senior Systems Administrator
IT Resources - University of Tasmania

More information about the ag-tech mailing list