[AG-TECH] Troubles Accessing Venues: some more clarification...

Fabrizio.Berdondini at prototipo.it Fabrizio.Berdondini at prototipo.it
Tue May 9 03:59:01 CDT 2006

Hello Tom and all,
due to the high number of threads/replies about this matter, i'm going to 
point out the main issues/tries done by me and my fellows in this days. 

- Elements of our system:
1) VenueServer for AG2.4
2) VenueServer for AG3.0
3) A number of clients for AG2.4 (some desktop machines, the notebook of 
my fellows, my notebook)
4) Two clients for AG 3.0 (my notebook and the one of one of my fellows)

All the clients should have, as far as now, all ports opened for TCP/UDP.

- First Try: inside LAN
In this first configuration all the above mentionned machines (both 
clients and servers) where connected inside our LAN.
We tried to connect all the 2.4 clients to the VenueServer without any 
problem (we got a certificate for each user/machine), we tried text chat, 
shared applications, videoconference, all was fine.
No problem also connecting the two AG3 clients to the AG3 VenueServer.

- Second Try: public IP for VenueServers
In this second configuration we gave a public IP to the two VenueServer 
machines,  *same* configuration for the client machines. We also run an 
"extra" VenueClient on both the 2.4 and 3.0 server machines, each one 
connected to the "local" lobby venue.
When we tried to connect to the lobby venue with the AG2.4 clients the 
connection was refused, saying the venue was unreachable. However looking 
onto the VenueClient running on the server machine (the "extra" one) I can 
see the clients as they were connected to the venue (but no audio-video of 
course). If we try many times to connect to the lobby venue with the 
clients, we can see  as many instances of each client as the number of 
trials we did to connect it to that venue.
No trouble, however, for connecting the AG3 clients to the server.

- Third try: the AG2/AG3 lobby at ANL
When connected to the lobby venue for AG2.4/3 at the ANL node, I cannot 
see audio/video from other users (i cannot see their names into VIC and 
RAT btw). Furthermore, obviously, i guess they cannot see my video or ear 
my audio.
We after tried this: I connected to the lobby venue at ANL and asked to 
one of my fellows to also connect to it. We can see each other, our names 
appear into the VIC and RAT instances but we don't receive/transmit 
audio/video from/to other users into the venue.
I got one more error when connecting to the AG3 lobby at ANL: one message 
raises up telling i'm not able to connect to the venue, but suddenly I 
appear into the venue and VIC and RAT are correctly loaded (of course I 
cannot receive audio/video from others, except the one of my fellow).

After this, I guess there could be some problem into our network/subnet 
configuration. Anyone could help?
Thank you in advance,
Faber B.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/ag-tech/attachments/20060509/dbd0a1b3/attachment.htm>

More information about the ag-tech mailing list