[AG-TECH] Probs starting VIC&RAT on AGTK3.01 winxp

Sebastian Adams sad at ceh.ac.uk
Fri Jun 2 08:47:56 CDT 2006

Hi there,

Just checked for any possible conflicts with the directory paths and there
aren't any unfortunately. In fact installing as a completely different user
into c:\documents and settings\userx\application... also displays the same

Pinning down when the app stopped working is a bit hard as I wasn't involved
at the time but I think it was after a reimage of the machine as well further
applications being installed.

Oddly enough in the venueclient.log the command to run the videoconsumer service
seems to run OK:

06/02/06 11:59:24 992 ServiceManager     agservicemanager.py:102 INFO  AGServiceManager.AddService
06/02/06 11:59:24 992 ServiceManager     agservicemanager.py:131 INFO  Extracting service package to C:\Documents and Settings\JWW\Application Data\AccessGrid3\local_services\VideoConsumerService
06/02/06 11:59:24 992 ServiceManager     agservicemanager.py:374 DEBUG Executing service VideoConsumerService
06/02/06 11:59:24 992 ServiceManager     agservicemanager.py:406 INFO  Running Service; options: ['C:\\Documents and Settings\\JWW\\Application Data\\AccessGrid3\\local_services\\VideoConsumerService\\VideoConsumerService.py', '--port', 57899, '--serviceManagerUri', 'http://lapc024.nerc-lancaster.ac.uk:11000/ServiceManager', '--token', 'c0ab9a180f6c420a2d0ce706262ff3c4']
06/02/06 11:59:24 992 ProcessManager     processmanager.py:62 DEBUG Creating process: C:\Python23\pythonw.exe "C:\Documents and Settings\JWW\Application Data\AccessGrid3\local_services\VideoConsumerService\VideoConsumerService.py" --port 57899 --serviceManagerUri http://lapc024.nerc-lancaster.ac.uk:11000/ServiceManager --token c0ab9a180f6c420a2d0ce706262ff3c4
06/02/06 11:59:24 992 ProcessManager     processmanager.py:75 DEBUG Create process returns: (<PyHANDLE:1132>, <PyHANDLE:1100>, 956, 916)
06/02/06 11:59:25 992 ServiceManager     agservicemanager.py:418 INFO  Service registered: http://lapc024.nerc-lancaster.ac.uk:57899/Services/VideoConsumerService.c0ab9a1803bc420a2d4e1765379463c6 c0ab9a180f6c420a2d0ce706262ff3c4

I've err
icting somehow? (as the machine has got
some of the out of ordinary software installed - stats/scientific/java development stuff)

Any further suggestions would greatfully received :)
Many thanks, Seb

>>> "Thomas D. Uram" <turam at mcs.anl.gov> 02 June 2006 14:14:01 >>>
I would expect to find some conflict like the one you've already sought.

In addition to looking for files like "c:\documents" , have you looked for
a conflict with "c:\documents and settings\jww\application" ? 

The fact that it worked at some point and has stopped makes me suspect
that a conflicting file has appeared in one of these locations.

We'll fix this problem in a future release.  Let me know how things work
out for you so we can be sure to address the problem you're seeing, if
it turns out to be something new.


Sebastian Adams wrote:
> Hi there,
> One of the machines here has an odd prob starting the vic & rat executables. Example error:
> eg audioservice.log
> 06/02/06 12:00:27 2984 Toolkit     agservice.py:182 INFO  SetStream: ignoring trivial re-configuration
> 06/02/06 12:00:27 2984 Toolkit     audioservice.py:274 INFO  Starting AudioService
> 06/02/06 12:00:27 2984 Toolkit     audioservice.py:275 INFO   executable = C:\Documents and Settings\JWW\Application Data\AccessGrid3\local_services\AudioService\rat.exe
> 06/02/06 12:00:27 2984 Toolkit     audioservice.py:277 INFO   options = ['-C', u'AGSC Venue Server Lobby', '-S', u'c0ab9a180f6c420a2c48365f6d2f3d12', '-f', 'L16-16K-Mono', u'sam.ag.manchester.ac.uk/10824']
> 06/02/06 12:00:27 2960 ProcessManager     processmanager.py:138 ERROR couldn't shutdown process <PyHANDLE:660>: (1444, 'PostThreadMessage', 'Invalid thread identifier.')
> Traceback (most recent call last):
>   File "C:\Python23\lib\site-packages\AccessGrid3\AccessGrid\Platform\win32\ProcessManager.py", line 131, in TerminateProcess
>     win32api.PostThreadMessage(self.threadid[pid], 18, 0, 0)
> error: (1444, 'PostThreadMessage', 'Invalid thread identifier.')
> 06/02/06 12:00:27 2984 ProcessManager  
ting process: C:\Documents and Settings\JWW\Application Data\AccessGrid3\local_services\AudioService\rat.exe -C "AGSC Venue Server Lobby" -S c0ab9a180f6c420a2c48365f6d2f3d12 -f L16-16K-Mono sam.ag.manchester.ac.uk/10824
> 06/02/06 12:00:27 2984 ProcessManager     processmanager.py:100 ERROR process creation failed: (193, 'CreateProcess', '%1 is not a valid Win32 application.')
> Traceback (most recent call last):
>   File "C:\Python23\lib\site-packages\AccessGrid3\AccessGrid\Platform\win32\ProcessManager.py", line 73, in StartProcess
>     startup_info)
> error: (193, 'CreateProcess', '%1 is not a valid Win32 application.')
> similarlarly for vic (videoproducerservice.log):
> 06/02/06 12:14:08 2884 Toolkit     videoproducerservice.py:324 INFO    enabled: 1
> 06/02/06 12:14:08 2884 Toolkit     agservice.py:171 INFO  SetStream: [consume
> ster.ac.uk 10194
> 06/02/06 12:14:08 2884 Toolkit     videoproducerservice.py:175 INFO  Mapping windows device: Logitech QuickCam Pro 4000
> 06/02/06 12:14:08 2884 Toolkit     videoproducerservice.py:303 INFO  Starting VideoProducerService
> 06/02/06 12:14:08 2884 Toolkit     videoproducerservice.py:304 INFO   executable = C:\Documents and Settings\JWW\Application Data\AccessGrid3\local_services\VideoProducerService\vic.exe
> 06/02/06 12:14:08 2884 Toolkit     videoproducerservice.py:305 INFO   options = ['-u', 'C:/DOCUME~1/JWW/LOCALS~1/Temp/VideoProducerService_2920.vic', '-C', 'Logitech QuickCam Pro 4000', '-X', u'site=c0ab9a180f6c420a2c48365f6d2f3d12', u'sam.ag.manchester.ac.uk/10194']
> 06/02/06 12:14:08 2884 ProcessManager     processmanager.py:62 DEBUG Creating process: C:\Documents and Settings\JWW\Application Data\AccessGrid3\local_services\VideoProducerService\vic.exe -u C:/DOCUME~1/JWW/LOCALS~1/Temp/VideoProducerService_2920.vic -C "Logitech QuickCam Pro 4000" -X site=c0ab9a180f6c420a2c48365f6d2f3d12 sam.ag.manchester.ac.uk/10194
> 06/02/06 12:14:08 2884 ProcessManager     processmanager.py:100 ERROR process creation failed: (193, 'CreateProcess', '%1 is not a valid 
> Traceback (most recent call last):
>   File "C:\Python23\lib\site-packages\AccessGrid3\AccessGrid\Platform\win32\ProcessManager.py", line 73, in StartProcess
>     startup_info)
> error: (193, 'CreateProcess', '%1 is not a valid Win32 application.')
> So it looks like python getting confused with the path/arguments or somesuch? I have checked that there isn't a directory called c:\documents which could cause this prob.
> I can start (without probs) vic & rat with the correct arguments via command line.
> At first I thought it was another application (statistica) installed on the PC which uses the .svc extension for macros - but have uninstalled that without resolution.
> AGTK has worked the machine in the past but has stopped working at some point (both agtk 2.4 & 3.01 exhibit the same prob).
> Many thanks, Seb
> Seb Adams
> CEH Computer Support
> Tel 01524 595818

This message (and any attachments) is for the recipient only. NERC
is subject to the Freedom of Information Act 2000 and the contents
of this email and any reply you make may be disclosed by NERC unless
it is exempt from release under the Act. Any material supplied to
NERC may be stored in an electronic records management system.

More information about the ag-tech mailing list