[AG-TECH] Update: SuSE 9.3 RPMs

Jeremy Mann jeremy at biochem.uthscsa.edu
Wed Sep 14 09:59:01 CDT 2005

Douglas, I fixed it. It wasn't building the SOAP modules because SuSE 9.3
x86_64 doesn't come with the fpconst python module. After installing
fpconst 0.7.2 and restarting the Build script, it finally worked. One
other thing, I had to make some changes in the SPEC file.

Now I finally have a 9.3 x86_64 rpm for AG and associated programs. I'm
keeping these in a safe place ;)

Douglas Kosovic said:
> BuildSnapshot.py calls BuildPythonModules.py which builds SOAPpy-0.11.4
> with
> the equivalent of the following sequence of events happening, you could
> try
> to reproduce it on the command-line to see if there is a problem with
> building SOAPpy:
>   cd SOAPpy-0.11.4
>   python setup.py clean --all
>   python setup.py build
>   python setup.py install
> --prefix=../dist-20050914/lib/python2.4/site-packages --no-compile
> Note: the files are put in a 'lib' dir instead of a 'lib64' dir, so the
> AccessGrid RPM spec file recitifies it latter by doing the following:
>   mv lib/python%{pyver}/site-packages/*
> usr/lib64/python%{pyver}/site-packages
> Also make sure you have all the gpt, globus-accessgrid, wxpython/wxGTK
> x86_64
> RPMs installed and not just the i386/i586 versions.
> The x86-64 mods in the AccessGrid.spec.in file were the ones I used for
> x86-64
> Fedora Core 3. I no longer have access to any PC running x86-64 linux at
> the
> moment.
> Cheers,
> Doug

Jeremy Mann
jeremy at biochem.uthscsa.edu

University of Texas Health Science Center
Bioinformatics Core Facility
Phone: (210) 567-2672

More information about the ag-tech mailing list