[AG-TECH] Problem with AG2.3 shared browser in Linux

Douglas Kosovic douglask at itee.uq.edu.au
Wed Oct 27 22:43:30 CDT 2004

Hi Andrew,

> After the usual thing about forgetting to delete the 2.2 code
> ~/.AccessGrid/SharedApplications/ I tried running this in Linux (RedHat
> 9).

> ImportError: /usr/lib/wxPython/lib/libwxmozilla_gtk2-2.4.so.0: undefined
> symbol: _ZNK10nsACString22GetImplementationFlagsEv

wxMozilla and Mozilla have to be built with the same version of g++. As you 
got Mozilla from mozilla.org, then most likely a different version of g++ 
was used.

> I have tried upgrading to gtk2-2.2.4-5.1 (from a FC1 distro) but no luck
> - RH9 had gtk2-2.2.1-4
> gtk2-2.4.0-1 from FC2 needs glib2, atk and pango upgraded ... this gets
> complex... rebuild wxmozilla from SRPM at uq.edu needs mozilla-devel and
> wxGTK2-devel which I don't have ...

I used wxGTK2 and wxPython from Fedora Extras:
 in their repsoitory you can find the corresponding devel RPMs.

It would be best to stick with the FC1 or RH9 RPMs available from Fedora 
Extras. The FC2 RPMs are linked against the Xorg libraries which will only 
give you grief on RH9. Then rebuild wxMozilla from the SRPM.

> I presume that upgrading to FC2 might solve this mess, but probably break
> other things like our production client ....

No, wxMozilla is still a mess with FC2, I have to rebuild wxmozilla from the 
SRPM every time Red Hat releases a Mozilla RPM upgrade for FC2. The 
SharedBrowser isn't quite usable yet as wxMozilla often core dumps in the 
GTK event loop. I just made SharedBrowser available for Fedora if some 
people want to experiment with it a bit.

SharedPresentation on the other hand is very usable on Fedora, as long as 
you don't use full-screen slideshow mode, but I think I might have a fix for 
the full-screen problem, I just need to test it.


More information about the ag-tech mailing list