[AG-TECH] VRM and ARM Missing HeartBeat

Rod Harris rod.harris at anu.edu.au
Thu Feb 13 22:35:42 CST 2003


	I have encountered a problem with the VRM and ARM event listeners not
getting the heartbeat from the display machine.

When I run vrm-eventlistener it claims it has connected to the display
machine (I've made sure all the scripts in /usr/local/ag/lib point to the
correct machine, and followed the advice from previous postings to this
list) but I get no heartbeat.

I've also tried running the arm-eventlistener on this machine but it also
gets no heartbeat.

However, when I run the arm-eventlistener on the audio machine I do get a
heartbeat (until I enter a room, at which time RAT will load up properly
but I'll loose the heartbeat).

I've tried using different JVMs (1.2.2, 1.2.2-14, 1.4.1-01) but that makes
no difference.

I've tried copying the scripts from the audio machine to the video machine,
but it still doesn't work.

And finally I booted the video machine into Windows and ran the VRM from
there and it does get the heartbeat.

I get this message when running the vrm-eventlistener (from Linux):

	Missed heartbeat!
	Mssed a second heartbeat, trying reconnect
	disconnect sdp channel listener
	Got newstate false
	create listener
	Got event channel
org.omg.CosEventChannelAdmin.StubForEventChannel:com.ooc.CORBA.Delegate at 84ce7a
	Got newstate true2
	reconnect succeeded!

and the display machine prints:

	cache returns sdp

The video machine is a dual Xeon running RH8.0.


More information about the ag-tech mailing list