[AG-TECH] Missed heartbeat - ORB problem

Mike Daw mike.daw at man.ac.uk
Thu Nov 22 06:27:08 CST 2001

Just to close a thread (unless anyone wants to comment...), I thought I'd
post what I found eventually to be the problem here.

In the file /etc/resolv.conf, I had the following entries:

search <my domain>
search <another domain>

When I ran netcfg, it showed:
Name: <machine name>
Domain: <another domain>

If I commented out the last 'search' line of resolv.conf (for <another
domain>) or moved it above the other search entry, I got a heartbeat and
netcfg showed the correct domain.

Incidentally, the suggestions from Kabe and Andrew about editing the host
file and putting in an entry for my audio machine got around the problem too
(but as my audio and video host files were previously the same and the video
machine worked fine, I knew this wasn't the whole story...).

Mike Daw
Computer Services for Academic Research (CSAR)
Manchester Computing, Kilburn Building, University of Manchester,
Manchester M13 9PL, UK
Tel: +44 (0)161 275 7026 Fax: +44 (0)161 275 6800
Email: mike.daw at man.ac.uk

On Wed, 21 Nov 2001, Mike Daw wrote:

> I'm having trouble with my audio machine and running arm-eventlistener.
> not getting a heartbeat. (By the way, I'm pretty sure this has nothing to
> with my /etc/hosts file or running set-display-machine as I've fiddled
> around in these areas for ages.)
> The error I'm getting from arm-eventlistener is:
> Warning: ORB::BOA_init: hostname lookup returned 'localhost' (
> Incidentally, it would be useful to look at the code that's outputting
> error, so I can see what exactly it's trying to do. Is it on RedHat AG
> distribution? If so, where is it?

More information about the ag-tech mailing list