types

Robert Olson olson at mcs.anl.gov
Wed Dec 11 09:47:09 CST 2002


At 05:58 PM 12/10/2002 -0600, Thomas Uram wrote:

>Plus StreamDescription, which of course also looks similar, but adds a 
>capability.

Ah, right. I'd still like to have a different name for these than streams, 
as streams have a strong binding in my head to an individual data stream 
within a multimedia session (which of course is another heavily overloaded 
word).

>Does the authorizationPolicy fit in the attributes struct?

I don't think they get passed around to other bits of the system; I've been 
thinking that the description types are for that purpose.

Updated types attached. I'm still a little fuzzy on what exactly you intend 
for details on stream descriptions (or its new name) and capabilities.

--bob
-------------- next part --------------
type IconType {
iconType: string (png, jpg, etc)
iconData: base64string
}

type URIType {
uri: string
}

type VenueDescription {
name: string
description: string
URI: URIType
icon: IconType
attributes: struct
}

type ConnectionDescription {
name: string
description: string
URI: URIType
icon: IconType
attributes: struct
}

type DataDescription {
description: string
URI: URIType
icon: IconType
attributes: struct
storageType: enum { venue, user }
}

type ServiceDescription{
description: string
URI: URIType
icon: IconType
attributes: struct
}

type StreamDescription{
description: string
URI: URIType
icon: IconType
mediaType: ??
mediaAddress: IPAddress
mediaPort: int
attributes: struct
}

type ClientProfile {
clientType: enum { user, node }
name: string
email: string
phoneNumber: string
icon: IconType
clientURI: URIType
clientInstanceId: string
techSupportInformation: string
capabilities: CapabilityDescriptionSequence
}

type ClientDescription {
profile: ClientProfile
clientDN: DistinguishedName
}

type CapabilityDescription {
...
}


More information about the ag-dev mailing list